Tag Archives: ssl

SharePoint Search Service – service implementation object was not initialized

As usually, the same opening statement.

“I recently bumped into this issue” where my Search Service Application services is throwing “service implementation object was not initialized” error when perform a regular, normal, nothing-special search from any sharepoint site collection.

Note that in my SharePoint Farm, I have two search server that are both hosting the 6 components

  • Admin Component
  • QueryProcessing Component
  • Index Component
  • Crawl Component
  • ContentProcessing Component
  • AnalysticProcessing Component

When accessing to Central Admin > Manage Service Application > Search Service Application page, I notice the “All Status” is “All Errors” and if it is hitting my another central admin server (i have 2, yea same server), it gives “Running”.

For this, I seem that there is some issue when server is trying to TALK to each other. Also, if  you browse into Search Schema (the old Managed Properties page), You do not see any managed properties to be configured.  Browsing to “Content Source” page will give you “Service Implementation object was not initialized” error

Flipping through my ULS logs for both server, you will see errors right below (putting the error here so it help Google Search for people hitting the same error and be able to find out my article that may be able to help them)

failed to get default collection for application Search Service Application: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: The service implementation object was not initialized
SearchServiceApplicationProxy::GetQueryHealthMonitoringSettingsForComponents--Error occurred:System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: The service implementation object was not initialized
Exception when reading aggregator settings: ...

All over the logs file.

It took me 7 rounds of re-provisioning of Search Service Application… in order to get it tested and fixed. I hope you do not need to spend that much time !

Occasionally, you see Error reported in Event Viewer

A failure was reported when trying to invoke a service application: EndpointFailure
Process Name: OWSTIMER
...
Service Application Uri: urn:schemas-microsoft-com:sharepoint:service: ...
...
Affected Endpoint: http:// xxxx /SearchService.svc

Resolution

All these are signs of SSL validation error that causing SVC end point failure. I followed this article (thanks to the author!) and trying to remove and add SSLCert with certification revocation disable.

  1. RDP to Search Server with Local Administrator rights
  2. Fire up “CMD” command prompt
  3. Execute
    netsh http show sslcert
  4. Note down the detail for ip port : 0.0.0.0:32844 (especially the Hash number) cause this is what the cert binding for SharePoint Web Service
    SharePoint SSL Cert binding revocation disable
  5. Execute command below to Delete the SSL binding
    netsh http delete sslcert ipport=0.0.0.0:32844
  6. You should see a success message. Then execute the following to add the SSL Binding with verify client certificate revocation Disabled
    netsh http add sslcert ipport=0.0.0.0:32844 certhash=18e363549ba0c0445625cc47ecbfb5dbbd4ec517
    appid={4dc3e181-e14b-4a21-b022-59fc669b0914}
    certstorename=SharePoint verifyclientcertrevocation=disableNote that the certhash should follow your own Cert.
  7. Repeat the same steps to all your Search Server
  8. Once it is added, I did a re-provisioning of my Search Service Application… And Woala!