Tag Archives: skype

WAMP SERVER is in Amber Color and cannot be started

Happened to bump into this hiccup and I thought it would be helpful to document it down.

Someone of you may have faced this error where your newly installed WAMP  cannot be started and there is no MYSQL/PHP/APACHE error log generated.

One place that I always like to check if the Event Viewer (eventvwr.msc). If you navigate to your Application Logs and happen to see this error

The Apache service named reported the following error:
>>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : AH00072: make_sock: could not bind to address 0.0.0.0:80 .

The Apache service named reported the following error:
>>> AH00451: no listening sockets available, shutting down .

The Apache service named reported the following error:
>>> AH00015: Unable to open logs .

Congratz! I may have a solution for you!

The above error simply means that the port 80 of your current machine is in used by another Running program…  Wait a minute.. I did not run any Web Server in my local machine.. Why would it be in used??

Step below show you how to check which program/service is using your ports

  1. Open CMD (Command Prompt) with Administrator rights
  2. Run “netstat -anob | more“. Use ” | more” in case the output is long and you need to see them page by page (hit Space to see next page of output, just so you know)
  3. Look for Local Address that contains “:80” port 80. (which is what the WAMP stack requires)
  4. You should see the executable that is using the port now. (In my Case, it was SKYPE.EXE… OKAY!! thanks for not telling me during my installation!)

 

Side Note, You can still use Skype for Business while hosting your WAMP Server. Go to Skype Option > Advanced > Connection. Uncheck the use port 80 443 for additional incoming connection.