Office Web Apps Sorry, there was a problem and we can’t open this document. If this happens again, try opening the document in Microsoft Word.

Got this error after configuring Office Web Apps for SharePoint.

officewebapp sorry there was a problem

Digging into the ULS for Office Web App [C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS\***] and found the following error messages when browsing a document via OWA

HttpRequestAsync, (WOPICheckFile,WACSERVER) no response [WebExceptionStatus:ConnectFailure, url: xxxxxxx
...syncResult asyncResult, Exception& exception)

WOPI CheckFile: Catch-All Failure [exception:Microsoft.Office.Web.Common.EnvironmentAdapters.UnexpectedErrorException:
HttpRequest failed ---> Microsoft.Office.Web.Apps.Common.HttpRequestAsyncException:
No Response in WebException ---> System.Net.WebException:
Unable to connect to the remote server ....
FileUnknownException while loading the app....

 

Checking Application Event Logs and got the following error

Exception type: ExcelWebRendererException Exception message:
We couldn't find the file you wanted.
at Microsoft.Office.Excel.WebUI.EwaState.OpenWorkbook()
...

Turned out that this is due to certain URL not being resolvable by Office Web App Servers.

Here is the catch, the SharePoint Web Application of mine is using multiple Zonez for authentication. The default zone was used for internal servers (not registered in DNS) while Intranet Zone was used for all users.

After the SPWOPI binding is done, the OWA takes in the Default Zone URL whenever user accessing office document via Intranet Zone. The Default Zone’s URL is never set in DNS and hence error thrown.

Resolution

The workaround is to change the HOSTS file in OWA server (C:\Windows\System32\drivers\etc\hosts) to add in the IP of SharePoint Web Server with Default Zone’s URL.

Alternatively, if the Default URL is okay to be exposed to public. Please feel free to add in a DNS record.

6 thoughts on “Office Web Apps Sorry, there was a problem and we can’t open this document. If this happens again, try opening the document in Microsoft Word.

  1. Lida

    Hi

    office web apps installed in my server , first web application that created is using office web apps rightly, but i create second web application in my server, in this one when i try to open files i have this error :

    ” Sorry, there was a problem and we can’t open this PDF”

    it also happened with other files.

    office web apps service is activated in second web application

    please help me

    tnx

    Reply
    1. Ah Cheng Post author

      Can you also make sure that the URL for second web app is also added into your HOSTS file?
      You can do things like
      [IP] SPACE [URL1] SPACE [URL2]
      e.g. 10.1.1.1 webapp1.abc.com webapp2.abc.com

      Reply
  2. Lida

    yes, the URLs was added there.
    can it be the problem ? that the first site collection as same name as web application was not created first ?

    Reply
    1. Ah Cheng Post author

      No it shouldn’t be a problem as long as the Alternate Access Mapping is done correctly in SharePoint and the OWA server can talk to the SharePoint via the DEFAULT Zone’s URL used.

      Also, remember not to use “System Account” to view file via OWA. It won’t work.

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

AlphaOmega Captcha Classica  –  Enter Security Code